Modify

Opened 5 months ago

Closed 3 months ago

#47 closed enhancement (fixed)

"type" filter fails on "notify" command when "action" is "list"

Reported by: PauDat Hax <paudathax@…> Owned by: tha
Priority: minor Component: Corrade Progressive
Keywords: notify, list, type, filter Cc:

Description

when corrade is asked for a list of bound notifications of a type where NONE ARE BOUND, the response reports a binding of a different type.

example, where there is NO heartbeat notification bound:

command=notify&group=xxxx&password=yyyy&action=list&type=heartbeat

group=xxxx&command=notify&data=permission%2Chttp%3A%2F%2Fsim10668.agni.lindenlab.com%3A12046%2Fcap%2F09eac371-f22a-85ed-4f4d-a57aef6d2889%2Chtt . . . [and it actually lists three of the same type]

expected behavior would be to return nothing? workaround for now is to check return against requested. unknown what happens when one asks for a CSV of types, but i suspect an error like this also.

Attachments (0)

Change History (7)

comment:1 in reply to:  description Changed 5 months ago by PauDat Hax <paudathax@…>

Replying to PauDat Hax <paudathax@…>:version: 9.170.6469.38726, on the production SL grid

comment:2 Changed 5 months ago by office

In 610/Corrade:

  • Send proper list of notifications for the "notify" command when action is set to "list" (addresses #47).

comment:3 Changed 5 months ago by tha

Resolution: fixed
Status: newclosed

Hello and thanks for reporting! The changes from [610/Corrade] should resolve this issue. Please patch to the latest branch using Stitch for the changes to take effect. If the issue is not resolved, please re-open this ticket. Thank you!

comment:4 Changed 3 months ago by paudathax@…

Resolution: fixed
Status: closedreopened

i still see the problem with version: 9.170.6531.20456, but perhaps i'm not using the correct repository?

example:

CORRADE CMD: command=notify&group=(redacted)&password=(redacted)=list&type=economy

CORRADE RESULT: group=(redacted)&command=notify&data=message%2Chttp%3A%2F%2F(redacted)%2Clocal%2Chttp%3A%2F%2Fsim10685.agni.lindenlab.com%3A12046%2Fcap%2Fcd36019f-e14f-e6c0-c3fb-777c01b38a1d%2Cpermission%2Chttp%3A%2F%2Fsim10668.agni.lindenlab.com%3A12046%2Fcap%2F09eac371-f22a-85ed-4f4d-a57aef6d2889%2Chttp%3A%2F%2Fsim10668.agni.lindenlab.com%3A12046%2Fcap%2F33eca825-0b9a-e9dc-2fa0-9e0f2f442af0%2Chttp%3A%2F%2Fsim10668.agni.lindenlab.com%3A12046%2Fcap%2F6cbb9011-6604-124e-c11e-057ae84638c5%2Chttp%3A%2F%2Fsim10668.agni.lindenlab.com%3A12046%2Fcap%2F2c971ca2-20bd-126e-5f79-1856cd7e15e0%2Cavatars%2Chttp%3A%2F%2F(redacted)%2Cheartbeat%2Chttp%3A%2F%2F(redacted)&success=True&time=2017-11-21T14%3A38%3A32.437852Z

comment:5 in reply to:  4 Changed 3 months ago by tha

The command seems malformed; the pair: password=(redacted)=list should be password=(redacted)&action=list

Replying to paudathax@…:

CORRADE CMD: command=notify&group=(redacted)&password=(redacted)=list&type=economy

comment:6 Changed 3 months ago by tha

Owner: set to tha
Status: reopenedaccepted

Good day! Regardless of the previous malformatted message, this issue is now confirmed. Corrade currently only filters in case there is a match: if there is a bound notification, and a type is specified via the notify command, then Corrade will report only the specific notification. However, if there is no bound notification of the supplied type, then all bound notifications will be listed.

Since I do not see why this change would break any downstream scripts, I will push for implementing the behaviour you would have expected. Thank you!

comment:7 Changed 3 months ago by tha

Resolution: fixed
Status: acceptedclosed
Type: defectenhancement

Hello! The stitch repository has been updated in the latest branch to include the behaviour change that you have requested. To get the latest update, please either:

In case the feature is not properly implemented, please feel free to reopen the ticket. Thank you!

Modify Ticket

Action
as closed The owner will remain tha.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.