Modify

Opened 10 months ago

Closed 2 months ago

#11 closed defect (invalid)

Bot will be log off while corrade.exe is still running

Reported by: chakkichakki Resident Owned by: tha
Priority: major Component: Corrade Progressive
Keywords: Cc:

Description

Corrade 9.164
Bot will be offline after a while, but the corrade console won't be closed (corrade.exe is running).
It migh be related with outfit change, but not sure. The bot use changeappearance now.
Any my bot will have that problem, but can't except when. Some will happen soon after login, some could stay for 20hours
It happens also on 9.163.


The Corrade.log is not same always though, here is one of them. Since this trac regards it was spam, it is shorten.

13-05-2017 19:07:54 : fisaftere Resident : Park Fruits Basket : fisaftere Resident (df3a3d5e-6d06-4f1e-bb82-cc6857905788) : sit
13-05-2017 19:07:54 : fisaftere Resident : Park Fruits Basket : fisaftere Resident (df3a3d5e-6d06-4f1e-bb82-cc6857905788) : autopilot
13-05-2017 19:07:54 : fisaftere Resident : Corrade command error : System.AggregateException?: 1 つ以上のエラーが発生しました。one or more erros have been occured? ---> System.NullReferenceException?: オブジェクト参照がオブジェクト インスタンスに設定されていません。 obect refference is not set to object instance?

場所 wasOpenMetaverse.Inventory.UpdateInventoryRecursive?(GridClient? Client, InventoryFolder? root, UInt32 millisecondsTimeout, Boolean force)
場所 wasOpenMetaverse.Inventory.Attach(GridClient? Client, InventoryFolder? CurrentOutfitFolder?, InventoryItem? item, AttachmentPoint? point, Boolean replace, UInt32 millisecondsTimeout)
場所 Corrade.Corrade.CorradeCommands?.<>cDisplayClass281_55.<.cctor>b205(String r)
場所 System.Linq.Parallel.ForAllOperator?1.ForAllEnumerator1.MoveNext?(TInput& currentElement, Int32& currentKey)
場所 System.Linq.Parallel.ForAllSpoolingTask?`2.SpoolingWork?()
場所 System.Linq.Parallel.SpoolingTaskBase?.Work()
場所 System.Linq.Parallel.QueryTask?.BaseWork?(Object unused)
場所 System.Threading.Tasks.Task.Execute()
--- 内部例外スタック トレースの終わり --- end of stack trace?

:
:omited
:

13-05-2017 19:07:54 : fisaftere Resident : simulator disconnected : Gianno : NetworkTimeout?
13-05-2017 19:07:54 : fisaftere Resident : Park Fruits Basket : fisaftere Resident (df3a3d5e-6d06-4f1e-bb82-cc6857905788) : autopilot
13-05-2017 19:07:54 : fisaftere Resident : simulator disconnected : Jonesford Heights : NetworkTimeout?
13-05-2017 19:07:54 : fisaftere Resident : Park Fruits Basket : fisaftere Resident (df3a3d5e-6d06-4f1e-bb82-cc6857905788) : stand
13-05-2017 19:07:54 : fisaftere Resident : all simulators disconnected
13-05-2017 19:07:54 : fisaftere Resident : disconnected : NetworkTimeout?
13-05-2017 19:07:54 : fisaftere Resident : Park Fruits Basket : fisaftere Resident (df3a3d5e-6d06-4f1e-bb82-cc6857905788) : database
13-05-2017 19:07:54 : fisaftere Resident : simulator disconnected : Tyrnaeur : NetworkTimeout?
13-05-2017 19:44:00 : fisaftere Resident : Heartbeat : CPU: 0% RAM: 257MiB Uptime: 0d:23h:57m Commands: 9937 Behaviours: 706
13-05-2017 20:44:00 : fisaftere Resident : Heartbeat : CPU: 0% RAM: 256MiB Uptime: 1d:0h:56m Commands: 9937 Behaviours: 706

Attachments (2)

disable_multiple_simulator_connections.png (110.5 KB) - added by tha 9 months ago.
Corrade.log (114.2 KB) - added by anonymous 2 months ago.

Download all attachments as: .zip

Change History (28)

comment:1 Changed 10 months ago by tha

Owner: set to tha
Status: newaccepted

Hi! Thanks for reporting! The latest update ([537/Corrade]) should fix these issues but, if possible, please check whether that is the case. All changes have been pushed to Stitch latest and I will leave this open for now.

comment:2 Changed 9 months ago by chakkichakki Resident

Checking for nearly 20 hours. I got some types of results.

results of 8 bots
1:Eating much memory but worked for 20 hours (2 bots both in the adult mainland sim that occuered the sitting problem(kira came to check (Frodes)
2:Keeping log in but not accept commands (4 bots: 2 were in a private homestead: 2 were in adult mainland Gianno)
3:Running well without problems (2 bots: in a private homestead)

Corrade.log extract:
a bot Pattern "1";=====================================================================================

14-05-2017 06:40:39 : vettelson Resident : Heartbeat : CPU: 0% RAM: 122MiB Uptime: 0d:0h:58m Commands: 135 Behaviours: 17

14-05-2017 07:40:39 : vettelson Resident : Heartbeat : CPU: 0% RAM: 122MiB Uptime: 0d:1h:56m Commands: 299 Behaviours: 47

14-05-2017 10:07:41 : vettelson Resident : Heartbeat : CPU: 0% RAM: 361MiB Uptime: 0d:4h:17m Commands: 552 Behaviours: 268

14-05-2017 13:05:07 : vettelson Resident : Heartbeat : CPU: 0% RAM: 882MiB Uptime: 0d:7h:7m Commands: 1116 Behaviours: 463

14-05-2017 20:05:06 : vettelson Resident : Heartbeat : CPU: 0% RAM: 1881MiB Uptime: 0d:13h:54m Commands: 2556 Behaviours: 613

14-05-2017 22:05:05 : vettelson Resident : Heartbeat : CPU: 0% RAM: 2201MiB Uptime: 0d:15h:52m Commands: 2848 Behaviours: 655

15-05-2017 01:05:04 : vettelson Resident : <vettelson Resident>: Connecting to (216.82.52.158:13021)
15-05-2017 01:05:05 : vettelson Resident : Heartbeat : CPU: 0% RAM: 2632MiB Uptime: 0d:18h:49m Commands: 3272 Behaviours: 711
15-05-2017 01:05:16 : vettelson Resident : Park Fruits Basket : chakkichakki Resident (3e846fd9-067f-4302-988f-1bea66e542e1) : inventory
15-05-2017 01:05:18 : vettelson Resident : <vettelson Resident>: Successfully set appearance

15-05-2017 02:04:02 : vettelson Resident : <vettelson Resident>: Connecting to (216.82.52.158:13021)
15-05-2017 02:05:02 : vettelson Resident : <vettelson Resident>: Failed to get ACK for UseCircuitCode? packet
15-05-2017 02:05:02 : vettelson Resident : <vettelson Resident>: Failed to get ACK for UseCircuitCode? packet
15-05-2017 02:05:05 : vettelson Resident : Heartbeat : CPU: 0% RAM: 2782MiB Uptime: 0d:19h:48m Commands: 3504 Behaviours: 733
15-05-2017 02:05:37 : vettelson Resident : Park Fruits Basket : vettelson Resident (dc54282e-9b0c-450e-bf54-d0a2df8403d3) : database

15-05-2017 03:03:30 : vettelson Resident : <vettelson Resident>: Successfully set appearance
15-05-2017 03:03:30 : vettelson Resident : appearance set
15-05-2017 03:03:37 : vettelson Resident : Park Fruits Basket : chakkichakki Resident (3e846fd9-067f-4302-988f-1bea66e542e1) : getattachments
15-05-2017 03:05:04 : vettelson Resident : Heartbeat : CPU: 0% RAM: 2947MiB Uptime: 0d:20h:46m Commands: 3731 Behaviours: 755
15-05-2017 03:05:53 : vettelson Resident : Park Fruits Basket : vettelson Resident (dc54282e-9b0c-450e-bf54-d0a2df8403d3) : tell

Corrade.log of another bot Pattern "1" ============================================================================

15-05-2017 03:23:54 : xiexing Resident : Heartbeat : CPU: 0% RAM: 3663MiB Uptime: 0d:18h:49m Commands: 3893 Behaviours: 388
14-05-2017 08:50:34 : xiexing Resident : Heartbeat : CPU: 0% RAM: 187MiB Uptime: 0d:0h:58m Commands: 195 Behaviours: 22

Corrade.log of Pattern "2"===========================================================================================

14-05-2017 09:55:39 : kanzyzay Resident : Park Fruits Basket : kanzyzay Resident (2a1f11c3-75ca-4ee7-85eb-4dae69147abe) : autopilot
14-05-2017 09:56:27 : kanzyzay Resident : Park Fruits Basket : kanzyzay Resident (2a1f11c3-75ca-4ee7-85eb-4dae69147abe) : getprimitiveinventory
14-05-2017 10:00:23 : kanzyzay Resident : Park Fruits Basket : kanzyzay Resident (2a1f11c3-75ca-4ee7-85eb-4dae69147abe) : database
14-05-2017 10:01:02 : kanzyzay Resident : Park Fruits Basket : kanzyzay Resident (2a1f11c3-75ca-4ee7-85eb-4dae69147abe) : getprimitiveinventory
14-05-2017 10:03:33 : kanzyzay Resident : Heartbeat : CPU: 0% RAM: 126MiB Uptime: 1d:15h:59m Commands: 16306 Behaviours: 370
14-05-2017 11:03:33 : kanzyzay Resident : Heartbeat : CPU: 0% RAM: 125MiB Uptime: 1d:16h:58m Commands: 16306 Behaviours: 370
14-05-2017 12:03:32 : kanzyzay Resident : Heartbeat : CPU: 0% RAM: 124MiB Uptime: 1d:17h:56m Commands: 16306 Behaviours: 370
14-05-2017 13:03:32 : kanzyzay Resident : Heartbeat : CPU: 0% RAM: 125MiB Uptime: 1d:18h:55m Commands: 16306 Behaviours: 370
14-05-2017 14:03:32 : kanzyzay Resident : Heartbeat : CPU: 0% RAM: 123MiB Uptime: 1d:19h:54m Commands: 16306 Behaviours: 370
14-05-2017 15:03:32 : kanzyzay Resident : Heartbeat : CPU: 0% RAM: 122MiB Uptime: 1d:20h:53m Commands: 16306 Behaviours: 370
14-05-2017 16:03:32 : kanzyzay Resident : Heartbeat : CPU: 0% RAM: 124MiB Uptime: 1d:21h:51m Commands: 16306 Behaviours: 370
14-05-2017 17:03:31 : kanzyzay Resident : Heartbeat : CPU: 0% RAM: 125MiB Uptime: 1d:22h:50m Commands: 16306 Behaviours: 370
14-05-2017 18:03:31 : kanzyzay Resident : Heartbeat : CPU: 0% RAM: 124MiB Uptime: 1d:23h:49m Commands: 16306 Behaviours: 370
14-05-2017 19:03:31 : kanzyzay Resident : Heartbeat : CPU: 0% RAM: 127MiB Uptime: 2d:0h:48m Commands: 16306 Behaviours: 370
14-05-2017 20:03:31 : kanzyzay Resident : Heartbeat : CPU: 0% RAM: 125MiB Uptime: 2d:1h:47m Commands: 16306 Behaviours: 370
14-05-2017 21:03:31 : kanzyzay Resident : Heartbeat : CPU: 0% RAM: 125MiB Uptime: 2d:2h:46m Commands: 16306 Behaviours: 370
14-05-2017 22:03:30 : kanzyzay Resident : Heartbeat : CPU: 0% RAM: 128MiB Uptime: 2d:3h:44m Commands: 16306 Behaviours: 370
14-05-2017 23:03:30 : kanzyzay Resident : Heartbeat : CPU: 0% RAM: 125MiB Uptime: 2d:4h:43m Commands: 16306 Behaviours: 370
15-05-2017 00:03:30 : kanzyzay Resident : Heartbeat : CPU: 0% RAM: 125MiB Uptime: 2d:5h:42m Commands: 16306 Behaviours: 370
15-05-2017 01:03:30 : kanzyzay Resident : Heartbeat : CPU: 0% RAM: 126MiB Uptime: 2d:6h:41m Commands: 16306 Behaviours: 370
15-05-2017 02:03:30 : kanzyzay Resident : Heartbeat : CPU: 0% RAM: 127MiB Uptime: 2d:7h:39m Commands: 16306 Behaviours: 370
15-05-2017 03:03:29 : kanzyzay Resident : Heartbeat : CPU: 0% RAM: 124MiB Uptime: 2d:8h:38m Commands: 16306 Behaviours: 370
15-05-2017 04:03:29 : kanzyzay Resident : Heartbeat : CPU: 0% RAM: 126MiB Uptime: 2d:9h:37m Commands: 16306 Behaviours: 370

comment:3 Changed 9 months ago by tha

Thanks for the report chakkichakki, here are some comments and questions for the cases you mention:

  1. The memory issue has been reported before and it related to libomv somehow - no clue as of yet why, but it seems that in zones with a large amount of traffic, such as mainland sims or HUBs, libomv accumulates network packets and never releases them.
  2. You can try teleporting the bot if it does not accept commands; do the commands show up in the log files when you issue them and the bot does not respond? When the bot does not respond, can you log-in to Nucleus and do any stats show?

One possible solution for production to these issue could be to disable multiple simulator connections (picture attached). Connecting to multiple simulators has the benefit of being able to detect and interact with avatars and primitives that are on neighbouring simulators. However, it is an experimental feature introduced in limbov on the very last stretch and it may be the cause for the mainland issues (or rather, issues that seem to appear when regions have adjacent simulators).

Could you please disable multiple simulator connections and perform your checks again? Especially checks related to Corrade being on regions with adjacent regions (ie: mainland). Thank you!

comment:4 Changed 9 months ago by chakkichakki Resident

With 9.164.6343.40242, they are all fine for 24 hours:) No memory problems also.
Very stable now.
Thank you Fantastic Corrade:)

comment:5 Changed 9 months ago by tha

Thank you! Did you disable multiple simulator connections or does the 9.164.6343.40242 update resolve the issue by itself?

comment:6 Changed 9 months ago by chakkichakki Resident

I'm sorry being late to reply.
MultipleSimulators? are enabled.
<EnableMultipleSimulators?>true</EnableMultipleSimulators?>

Memory usage is keeping 130MiB around without SIML setting.

But I didn't use my bot on the problematic sim recent days. So i will test them there today.

9.164.6343.40242

I will post further reports for that.

comment:7 Changed 9 months ago by chakkichakki Resident

The memory usage is stable for 24 hours on any regions for our bots.
9.164.6343.40242
Thank you :)

comment:8 Changed 9 months ago by tha

Resolution: fixed
Status: acceptedclosed

Thank you! If there are any more problems related to the same issue, please reopen. The fixes have been included in the latest 9.164 milestone and also added to Stitch. :-)

comment:9 Changed 4 months ago by DaxDupont

Resolution: fixed
Status: closedreopened

Reopening this, had a few instances where corrade would be disconnected from all regions but connected all the same.

08-10-2017 08:15:38 : clockwork Carver : simulator disconnected : Tulagi : NetworkTimeout?
08-10-2017 08:15:38 : clockwork Carver : all simulators disconnected
08-10-2017 08:15:39 : clockwork Carver : disconnected : NetworkTimeout?
08-10-2017 11:53:04 : clockwork Carver : Heartbeat : CPU: 0% RAM: 595MiB Uptime: 3d:17h:27m Commands: 10 Behaviours: 0
08-10-2017 21:53:04 : clockwork Carver : Heartbeat : CPU: 0% RAM: 596MiB Uptime: 4d:3h:25m Commands: 10 Behaviours: 0
09-10-2017 07:53:01 : clockwork Carver : Heartbeat : CPU: 0% RAM: 596MiB Uptime: 4d:13h:22m Commands: 10 Behaviours: 0

11-10-2017 16:45:13 : clockwork Carver : simulator disconnected : Tulagi : NetworkTimeout?
11-10-2017 16:45:13 : clockwork Carver : all simulators disconnected
11-10-2017 16:45:13 : clockwork Carver : disconnected : NetworkTimeout?
11-10-2017 18:19:53 : clockwork Carver : Heartbeat : CPU: 0% RAM: 475MiB Uptime: 2d:1h:45m Commands: 8 Behaviours: 0
12-10-2017 04:19:51 : clockwork Carver : Heartbeat : CPU: 0% RAM: 476MiB Uptime: 2d:11h:43m Commands: 8 Behaviours: 0

All disconnected should result in an exit and restart/retry.

comment:10 Changed 4 months ago by tha

Status: reopenedaccepted

Hi! We are experiencing some difficulties and are currently on holiday. The project is no abandoned and will resume when the shitstorm is over. In the interim, please install Corrade as a service since these issues may be related to the way Windows handles command prompts. Thanks for reporting!

Last edited 4 months ago by tha (previous) (diff)

comment:11 Changed 4 months ago by office

In 611/Corrade:

  • Tentatively fix issues for half-open disconnect on all simulator disconnect (addresses #11).
  • Explicitly check that command output on POST data submission is not NULL (addresses #48).
  • Update external packages such as Syn.Bot.

comment:12 Changed 4 months ago by tha

Hello! A tentative fix has been released and pushed to the Stitch 'latest' channel. Could you please stitch to latest and check whether the issue has been resolved or if the behaviour persists? Thanks!

comment:13 Changed 4 months ago by glowworm@…

Still Fails. Half a day maximum, this and the last two versions. Last working version was 9.167

09-11-2017 05:03:50 : Zzzzzzzz Resident : Heartbeat : CPU: 3% RAM: 604MiB Uptime: 0d:2h:47m Commands: 8 Behaviours: 0
09-11-2017 05:34:46 : Nianfo Resident : simulator disconnected : Xxx : NetworkTimeout
09-11-2017 05:34:46 : Nianfo Resident : simulator disconnected : Yyy : NetworkTimeout
09-11-2017 05:34:46 : Nianfo Resident : all simulators disconnected
09-11-2017 05:34:46 : Nianfo Resident : disconnected : NetworkTimeout

ps -ef | grep corrade
corrade  10660     1  3 02:03 ?        00:14:58 /usr/bin/mono /usr/lib/mono/4.5/mono-service.exe -l:/home/corrade/Zzzzzzz/Corrade.exe.lock ./Corrade.exe

comment:14 in reply to:  13 Changed 3 months ago by tha

Replying to glowworm@…:

Corrade is not supported on mono and due to mono not being compliant with .NET, the behaviour must be confirmed on a platform that runs of the official .NET 4.5.1 Framework (or up).

We can do that for you though - would you mind sharing the following:

  • does the bot you mention move between simulators a lot?
    • if the bot stays on a single simulator, could you tell us which simulator? We can deploy a drone there and try to reproduce the issue.

As far as the current information stands, this issue seems to be related to Corrade running in a console on Windows - unless somebody confirms that the same issue is present when running as a service.

The issue may be tough to reproduce, perhaps simulator / region related - the attached screenshot shows Ectogram Resident running for about three weeks without this issue occurring:

http://scratch.grimore.org/f0wdluop

comment:15 Changed 3 months ago by office

In 612/Corrade:

  • Save group members when they are counted.
  • Simplify forced logout when Corrade is cycling simulators (addresses #11).
  • Uninstall only rebound event handlers (addresses #11).

comment:16 Changed 3 months ago by tha

An update has been pushed through Stitch: please remember to stitch from http://corrade.grimore.org by using the -s flag and to specify --no-geolocation because some repositories may not have been updated.

Further to this issue, the following things should be checked:

  • Corrade absolutely requires user-intervention when running under a non-administrator account on Windows as a console application. Corrade will stall and spin until UAC has been answered and privileges elevated - this is due to the various HTTP servers needing superuser privileges to start. To eliminate this point, simply run Corrade as a service since services implicitly have the required privileges granted.
  • Running Corrade without the auto scripted-agent status feature - in order to eliminate the possibility that setting and unsetting the status may prevent Corrade from cycling.
  • A new command cycle has been added that, contrary to logout will make Corrade disconnect and connect to the next simulator on the list. You can use the cycle command to check whether Corrade performs the reconnect cycle without errors.
Last edited 3 months ago by tha (previous) (diff)

comment:17 Changed 3 months ago by anonymous

Still fails.

Scripted agent status is off and has always been for me as I have set it myself and don't need the bot always undoing it/doing it, btw, this is one setting I have to reset in the .ini every time as Stitch doesn't retain that line.

This time I started my bot and immediately teleported him to another region that is public accessable. http://maps.secondlife.com/secondlife/Surfies and the failure happened inside 2 hours. I don't think it's sim related but you are very welcome to place a bot in this sim for testing

He is logged out, the process is still running. No simulator disconected messages in the logs now. But the log messages are now different. this time...

11-11-2017 20:43:04 : Nianfo Resident : logging in : home
11-11-2017 20:43:09 : Nianfo Resident : Connecting to simulator
11-11-2017 20:43:10 : Nianfo Resident : simulator connected : Xxx
11-11-2017 20:43:10 : Nianfo Resident : login succeeded
11-11-2017 20:43:11 : Nianfo Resident : event queue started : Xxx
11-11-2017 20:43:13 : Nianfo Resident : inventory cache items loaded : 4141
11-11-2017 20:43:23 : Nianfo Resident : simulator connected : Yyy
11-11-2017 20:43:23 : Nianfo Resident : appearance set
11-11-2017 20:43:28 : Nianfo Resident : event queue started : Yyy
11-11-2017 20:44:48 : Nianfo Resident : simulator connected : Surfies
11-11-2017 20:44:48 : Nianfo Resident : teleport succeeded
11-11-2017 20:44:48 : Nianfo Resident : event queue started : Surfies
11-11-2017 20:44:48 : Nianfo Resident : appearance set
11-11-2017 20:45:37 : Nianfo Resident : simulator disconnected : Yyy : NetworkTimeout
11-11-2017 20:45:37 : Nianfo Resident : simulator disconnected : Xxx : NetworkTimeout
11-11-2017 20:46:04 : Nianfo Resident : inventory cache items saved : 4544
11-11-2017 21:43:28 : Nianfo Resident : Heartbeat : CPU: 0% RAM: 382MiB Uptime: 0d:0h:48m Commands: 0 Behaviours: 0
11-11-2017 22:43:28 : Nianfo Resident : Heartbeat : CPU: 0% RAM: 488MiB Uptime: 0d:1h:45m Commands: 0 Behaviours: 0
11-11-2017 23:43:28 : Nianfo Resident : Heartbeat : CPU: 0% RAM: 614MiB Uptime: 0d:2h:44m Commands: 0 Behaviours: 0

and the log stops here. Openmetaverse log isn't time stamped so I can't correlate the logout time

comment:18 in reply to:  17 Changed 3 months ago by tha

Replying to anonymous:

If the logs are accurate, then Corrade is still connected to the Surfies simulator and will hence not attempt to relog.

Thank you for giving an example simulator - a drone has been deployed but the behavior has not yet been observed. Could you please specify whether you are running from console or as a service?

Also, please update to latest Stitch because the very last update may be related.

Thank you!

11-11-2017 20:43:04 : Nianfo Resident : logging in : home
11-11-2017 20:43:09 : Nianfo Resident : Connecting to simulator
11-11-2017 20:43:10 : Nianfo Resident : simulator connected : Xxx
11-11-2017 20:43:10 : Nianfo Resident : login succeeded
11-11-2017 20:43:11 : Nianfo Resident : event queue started : Xxx
11-11-2017 20:43:13 : Nianfo Resident : inventory cache items loaded : 4141
11-11-2017 20:43:23 : Nianfo Resident : simulator connected : Yyy
11-11-2017 20:43:23 : Nianfo Resident : appearance set
11-11-2017 20:43:28 : Nianfo Resident : event queue started : Yyy
11-11-2017 20:44:48 : Nianfo Resident : simulator connected : Surfies
11-11-2017 20:44:48 : Nianfo Resident : teleport succeeded
11-11-2017 20:44:48 : Nianfo Resident : event queue started : Surfies
11-11-2017 20:44:48 : Nianfo Resident : appearance set
11-11-2017 20:45:37 : Nianfo Resident : simulator disconnected : Yyy : NetworkTimeout
11-11-2017 20:45:37 : Nianfo Resident : simulator disconnected : Xxx : NetworkTimeout
11-11-2017 20:46:04 : Nianfo Resident : inventory cache items saved : 4544
11-11-2017 21:43:28 : Nianfo Resident : Heartbeat : CPU: 0% RAM: 382MiB Uptime: 0d:0h:48m Commands: 0 Behaviours: 0
11-11-2017 22:43:28 : Nianfo Resident : Heartbeat : CPU: 0% RAM: 488MiB Uptime: 0d:1h:45m Commands: 0 Behaviours: 0
11-11-2017 23:43:28 : Nianfo Resident : Heartbeat : CPU: 0% RAM: 614MiB Uptime: 0d:2h:44m Commands: 0 Behaviours: 0

comment:19 Changed 3 months ago by tha

Resolution: fixed
Status: acceptedclosed

Hello! Multiple sources have confirmed that the issue has now been resolved by stitching to the latest update (by supplying the --no-gelocation parameter). In case the issue re-surfaces in the future, please feel free to re-open the ticket.

comment:20 Changed 3 months ago by aphroditeatlas@…

9.170 is crashing - drops off the grid, service appears to remain running. Here are some corrade.log lines from before and after the last crash on 9.170; 9.168 doesn't crash in this manner, FWIW.

22-11-2017 13:04:11 : Wooly Morgwain : login succeeded
22-11-2017 13:04:11 : Wooly Morgwain : event queue started : Badger
22-11-2017 13:04:12 : Wooly Morgwain : appearance set
22-11-2017 13:04:13 : Wooly Morgwain : Divine Textures : Aphrodite Atlas (5873b2fd-e730-4696-a60f-bfa65e34162b) : notify
22-11-2017 13:04:13 : Wooly Morgwain : simulator connected : Koscina
22-11-2017 13:04:14 : Wooly Morgwain : inventory cache items loaded : 11379
22-11-2017 13:04:38 : Wooly Morgwain : inventory cache items saved : 12216
22-11-2017 13:05:06 : Wooly Morgwain : event queue started : Koscina
22-11-2017 14:04:02 : Wooly Morgwain : Heartbeat : CPU: 0% RAM: 104MiB Uptime: 0d:0h:59m Commands: 1 Behaviours: 0
22-11-2017 15:04:02 : Wooly Morgwain : Heartbeat : CPU: 0% RAM: 108MiB Uptime: 0d:1h:58m Commands: 1 Behaviours: 0
22-11-2017 16:04:02 : Wooly Morgwain : Heartbeat : CPU: 0% RAM: 112MiB Uptime: 0d:2h:58m Commands: 1 Behaviours: 0
22-11-2017 17:04:02 : Wooly Morgwain : Heartbeat : CPU: 0% RAM: 116MiB Uptime: 0d:3h:58m Commands: 1 Behaviours: 0
22-11-2017 18:04:02 : Wooly Morgwain : Heartbeat : CPU: 0% RAM: 118MiB Uptime: 0d:4h:57m Commands: 1 Behaviours: 0
22-11-2017 19:04:02 : Wooly Morgwain : Heartbeat : CPU: 0% RAM: 122MiB Uptime: 0d:5h:57m Commands: 1 Behaviours: 0
22-11-2017 20:04:02 : Wooly Morgwain : Heartbeat : CPU: 0% RAM: 126MiB Uptime: 0d:6h:57m Commands: 1 Behaviours: 0
22-11-2017 21:04:02 : Wooly Morgwain : Heartbeat : CPU: 0% RAM: 130MiB Uptime: 0d:7h:56m Commands: 1 Behaviours: 0
22-11-2017 22:04:02 : Wooly Morgwain : Heartbeat : CPU: 0% RAM: 135MiB Uptime: 0d:8h:56m Commands: 1 Behaviours: 0
22-11-2017 23:04:02 : Wooly Morgwain : Heartbeat : CPU: 0% RAM: 140MiB Uptime: 0d:9h:56m Commands: 1 Behaviours: 0
23-11-2017 00:04:02 : Wooly Morgwain : Heartbeat : CPU: 0% RAM: 144MiB Uptime: 0d:10h:55m Commands: 1 Behaviours: 0
23-11-2017 01:04:02 : Wooly Morgwain : Heartbeat : CPU: 0% RAM: 148MiB Uptime: 0d:11h:55m Commands: 1 Behaviours: 0
23-11-2017 02:04:02 : Wooly Morgwain : Heartbeat : CPU: 0% RAM: 154MiB Uptime: 0d:12h:55m Commands: 1 Behaviours: 0
23-11-2017 03:04:02 : Wooly Morgwain : Heartbeat : CPU: 0% RAM: 158MiB Uptime: 0d:13h:54m Commands: 1 Behaviours: 0
23-11-2017 04:04:02 : Wooly Morgwain : Heartbeat : CPU: 0% RAM: 162MiB Uptime: 0d:14h:54m Commands: 1 Behaviours: 0
23-11-2017 05:04:02 : Wooly Morgwain : Heartbeat : CPU: 0% RAM: 166MiB Uptime: 0d:15h:54m Commands: 1 Behaviours: 0
23-11-2017 06:04:02 : Wooly Morgwain : Heartbeat : CPU: 0% RAM: 170MiB Uptime: 0d:16h:54m Commands: 1 Behaviours: 0
23-11-2017 07:04:02 : Wooly Morgwain : Heartbeat : CPU: 1% RAM: 175MiB Uptime: 0d:17h:53m Commands: 1 Behaviours: 0
23-11-2017 08:04:02 : Wooly Morgwain : Heartbeat : CPU: 0% RAM: 179MiB Uptime: 0d:18h:53m Commands: 1 Behaviours: 0
23-11-2017 09:04:02 : Wooly Morgwain : Heartbeat : CPU: 1% RAM: 184MiB Uptime: 0d:19h:53m Commands: 1 Behaviours: 0
23-11-2017 10:04:02 : Wooly Morgwain : Heartbeat : CPU: 0% RAM: 188MiB Uptime: 0d:20h:52m Commands: 1 Behaviours: 0
23-11-2017 11:04:02 : Wooly Morgwain : Heartbeat : CPU: 0% RAM: 193MiB Uptime: 0d:21h:52m Commands: 1 Behaviours: 0
23-11-2017 12:04:02 : Wooly Morgwain : Heartbeat : CPU: 0% RAM: 197MiB Uptime: 0d:22h:52m Commands: 1 Behaviours: 0
23-11-2017 13:04:02 : Wooly Morgwain : Heartbeat : CPU: 1% RAM: 203MiB Uptime: 0d:23h:51m Commands: 1 Behaviours: 0
23-11-2017 14:04:02 : Wooly Morgwain : Heartbeat : CPU: 1% RAM: 206MiB Uptime: 1d:0h:51m Commands: 1 Behaviours: 0
23-11-2017 15:04:00 : Wooly Morgwain : Heartbeat : CPU: 0% RAM: 211MiB Uptime: 1d:1h:51m Commands: 1 Behaviours: 0
23-11-2017 15:32:14 : Wooly Morgwain : simulator disconnected : Koscina : NetworkTimeout?
23-11-2017 15:32:14 : Wooly Morgwain : simulator disconnected : Badger : NetworkTimeout?
23-11-2017 15:32:14 : Wooly Morgwain : all simulators disconnected
23-11-2017 15:32:14 : Wooly Morgwain : disconnected : NetworkTimeout?
23-11-2017 16:04:00 : Wooly Morgwain : Heartbeat : CPU: 0% RAM: 213MiB Uptime: 1d:2h:51m Commands: 1 Behaviours: 0
23-11-2017 17:04:00 : Wooly Morgwain : Heartbeat : CPU: 0% RAM: 213MiB Uptime: 1d:3h:50m Commands: 1 Behaviours: 0
23-11-2017 18:04:00 : Wooly Morgwain : Heartbeat : CPU: 0% RAM: 213MiB Uptime: 1d:4h:50m Commands: 1 Behaviours: 0
23-11-2017 19:04:00 : Wooly Morgwain : Heartbeat : CPU: 0% RAM: 213MiB Uptime: 1d:5h:50m Commands: 1 Behaviours: 0
23-11-2017 20:04:00 : Wooly Morgwain : Heartbeat : CPU: 0% RAM: 213MiB Uptime: 1d:6h:49m Commands: 1 Behaviours: 0
23-11-2017 21:04:00 : Wooly Morgwain : Heartbeat : CPU: 0% RAM: 213MiB Uptime: 1d:7h:49m Commands: 1 Behaviours: 0
23-11-2017 22:04:00 : Wooly Morgwain : Heartbeat : CPU: 0% RAM: 213MiB Uptime: 1d:8h:49m Commands: 1 Behaviours: 0
23-11-2017 23:04:00 : Wooly Morgwain : Heartbeat : CPU: 1% RAM: 213MiB Uptime: 1d:9h:48m Commands: 1 Behaviours: 0
24-11-2017 00:04:00 : Wooly Morgwain : Heartbeat : CPU: 0% RAM: 213MiB Uptime: 1d:10h:48m Commands: 1 Behaviours: 0
24-11-2017 01:04:00 : Wooly Morgwain : Heartbeat : CPU: 0% RAM: 213MiB Uptime: 1d:11h:48m

comment:21 Changed 3 months ago by aphroditeatlas@…

I'm on win10, fully up to date. Bot crashed silently from the grid but the service is still running, to wit:

04-12-2017 08:02:44 : Wooly Morgwain : simulator disconnected : Koscina : NetworkTimeout?
04-12-2017 08:02:44 : Wooly Morgwain : simulator disconnected : Badger : NetworkTimeout?
04-12-2017 08:02:44 : Wooly Morgwain : all simulators disconnected
04-12-2017 08:02:44 : Wooly Morgwain : disconnected : NetworkTimeout?
04-12-2017 09:01:33 : Wooly Morgwain : Heartbeat : CPU: 0% RAM: 142MiB Uptime: 0d:10h:54m Commands: 1 Behaviours: 0

Corrade version 9.170.6531.20456

comment:22 Changed 3 months ago by anonymous

Resolution: fixed
Status: closedreopened

comment:23 Changed 3 months ago by tha

Resolution: fixed
Status: reopenedclosed

Hello and thanks for reporting. The latest Corrade version is currently at 9.172 - if you can reproduce the error on the latest release, please reopen this ticket.

Changed 2 months ago by anonymous

Attachment: Corrade.log added

comment:24 Changed 2 months ago by anonymous

Corrade continues to crash silently from the grid but remain running as a service. I've uploaded my log and here's a screenshot showing the version I'm on.

https://gyazo.com/d02a4d595c7157ab8dacaee97bf22f33

comment:25 Changed 2 months ago by anonymous

Resolution: fixed
Status: closedreopened

comment:26 Changed 2 months ago by office

Resolution: invalid
Status: reopenedclosed

Please see #55 and cross-posting huge log files on previous tickets that have been addressed does not speed up a resolution: neither your particular problem will be solved nor does it add anything of value to the original ticket.

Modify Ticket

Action
as closed The owner will remain tha.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.